I’ve been trying to run one of my research ASP.NET application on Ubuntu. I kept getting an error some very obscure error message that says "Warning **: Missing method .ctor [..]" (for the entire message see this post. After long research on the web, I found that my mono installation is out of date and my application is written in .NET Framework 4.

To support newer version of .NET Framework, I have to update my Mono from version 2.6 to 2.10 which is only provided by BadgerPorts. See my previous post “Install MonoDevelop on Ubuntu” to configure Ubuntu software source to use BadgerPorts.

Once BadgerPorts has been added as a software source, do the following step:

  1. Go into System-> Administration -> Synaptic Package Manager
  2. Search for mono
  3. For each package mentioned here, click on the check box next to Package name and select “Mark for upgrade”

Restart Apache.